понедельник, 31 марта 2014 г.

Домашнее задание информатика


Задание 6

a/b + c/b = m/n

алг   Сложение дробей
цел   a, b, c, m, n
нач
      ввод a, b, c
     m:=a+c
     n:=b
     вывод m,n
кон

Задание 7


y= (1 - x^2  + 5x^4)^2
Пусть x=2, n=x^2, m=x^4, c=5x^4, k=1 - x^2, l=1 - x^2  + 5x^4, d=y

алг Вычисление
цел x, y, m, n, c, k, l, d
нач
      ввод x:=2
      n:=2x2
      m:=4x4
      c:=5x16
      k:=1-4
      l:=80-3
      d:=77x77
      d:=y
      y:=5929
      
вывод y
кон

среда, 5 марта 2014 г.

Параграф №30

Задание №7

  Составьте программу, переводящую ГРИС в угол поля из любого исходного положения.

Программа ПОЛОЖЕНИЕ
нач
пока впереди не стена
нц
прыжок
кц
поворот
пока впереди не стена
нц
прыжок
кц
кон

Задание №8

Составьте программу рисования прямоугольной рамки вдоль края поля при любом начальном состоянии исполнителя 
Программа РАМКА
нач
пока впереди не стена
нц
прыжок
кц
поворот
сделай ЛИН
сделай ЛИН
сделай ЛИН
сделай ЛИН
сделай ЛИН
кон
Процедура ЛИН
нач
пока впереди не стена
нц
шаг
кц
поворот
кон

понедельник, 3 марта 2014 г.

1.                                  
программа РОГ
нач
сделай РОГ
сделай РОГ
шаг
кон
процедура РОГ
нач
шаг
поворот
шаг
поворот
поворот
поворот
шаг
поворот
поворот
поворот
шаг
поворот
кон

программа КРЕСТ
нач
сделай КЕТ
сделай КЕТ
сделай КЕТ
сделай КЕТ
кон
процедура КЕТ
нач
шаг
поворот
шаг
поворот
поворот
поворот
шаг
поворот
поворот
поворот
кон
3)
программа НОС
нач
сделай Н
сделай О
сделай С

кон
процедура Н
нач
шаг
шаг
поворот
поворот
прыжок
поворот
поворот
поворот
шаг
поворот
прыжок
поворот
поворот
шаг
шаг
поворот
прыжок
кон
процедура О
нач
прыжок
поворот
шаг
шаг
поворот
шаг
поворот
шаг
шаг
поворот
шаг
прыжок
кон
процедура С
нач
поворот
шаг
шаг
поворот
поворот
поворот
шаг
поворот
поворот
поворот
прыжок
прыжок
поворот
поворот
поворот
шаг
кон
4)
программа ЛЕСТНИЦА
нач
сделай Г
сделай Г
сделай Г
кон
процедура Г
нач
шаг
поворот
поворот
поворот
шаг
поворот
поворот
поворот
кон